Email send via GC GO

Incident Report for GiveCampus

Resolved

As of 10:49a ET, the issue has been resolved, and all partner schools can now send emails via Microsoft Outlook once again. Multiple schools have since confirmed service has been restored.
Posted Jul 20, 2026 - 11:09 EDT

Identified

Schools using GC GO in combination with Microsoft Outlook are currently unable to send 1:1 constituent emails. We have identified the source of the issue and are working on a fix.
Posted Jul 20, 2026 - 10:43 EDT
This incident affected: GC GO (frontline fundraisers) and GC GO (students).