Emails are now successfully delivering to all Microsoft systems. If you experience any residual issues with email deliverability, please reach out to the GiveCampus support team.
Posted Aug 16, 2026 - 18:07 EDT
Update
Microsoft 365 enterprise users continue to experience intermittent issues receiving emails from GiveCampus and other email senders. So far, consumer addresses like Hotmail and Outlook.com appear to be unaffected. If you have any issues accessing your account as a result, contact support at support@givecampus.com. Our next update will be when Microsoft resolves this issue.
Posted Aug 16, 2026 - 11:40 EDT
Investigating
Like many email providers, GiveCampus is seeing delivery issues to Microsoft-hosted email addresses (such as Outlook, Hotmail, and Microsoft 365 accounts) affecting roughly 10-15% of messages sent through GC Outreach and system notifications (including 2-factor email notifications).
This is a Microsoft-side issue affecting many senders industry-wide, not specific to GiveCampus which we were alerted to by our upstream email provider Sendgrid: https://status.twilio.com/incidents/r2gvsly2y5ty. We're monitoring closely and will post an update as soon as we have more detail or Microsoft resolves it.
Posted Aug 15, 2026 - 17:40 EDT
This incident affected: GC Online Giving, GC Events, GC Volunteer Management, GC GO (frontline fundraisers), GC GO (students), and GC Outreach - Email & Texting.