Scheduled Maintenance March 1st

Scheduled for Mar 1, 01:00 - 02:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 12, 2026 - 23:13 EST

Scheduled

GiveCampus will be performing regularly scheduled maintenance on the platform on Sunday, March 1st between the hours of 1:00am and 2:00am ET. The site will be unreachable during this period.
Posted Jan 12, 2026 - 19:33 EST
This scheduled maintenance affects: GC Online Giving, GC Events, GC Volunteer Management, GC GO (frontline fundraisers), GC GO (students), GC Outreach - Email & Texting, and Platform Data Transfer (Data Importer, File Transfer, API).