Marketing Site Temporarily Unavailable

Incident Report for GiveCampus

Resolved

This issue has been resolved.
Posted Mar 10, 2026 - 09:43 EDT

Monitoring

Our engineers have mitigated the issue affecting our marketing website. Users should no longer experience problems accessing the site. Accessing GiveCampus for constituents and donors was not impacted. We will continue to monitor our downstream provider to ensure full stability.
Posted Mar 09, 2026 - 17:14 EDT

Identified

The downstream provider for our marketing website is currently experiencing issues. Accessing GiveCampus for constituents and donors is not impacted. If you need to log into GiveCampus, go to https://www.givecampus.com/login. We will post an update when our provider has restored service.
Posted Mar 09, 2026 - 12:05 EDT